More than half of mobile developers to require iOS 7 for their apps?

More than half of mobile developers to require iOS 7 for their apps?

Twitterrific developer Craig Hockenberry has posted the results of a small survey he performed over on his blog. As he was making his apps ready for iOS 7, Hockenberry wondered if many other developers out there are doing the same — dropping support for any version of iOS below iOS 7. So he ran an informal survey that attracted responses of 575 developers.

Unsurprisingly, he discovered that 95% of developers are working on updating their apps for iOS 7. However, what was kinda strange is that more than half (52%) of respondents said they will drop support for any iOS below iOS 7 in the next major version of their app.

Apparently there’s a ton of work involved to make an app compatible with both iOS 7 and earlier versions of the platform. So some developers are opting to leave owners of the older devices unsupported. That’s kinda strange, but hey – you can’t stop the progress. And with the iPhone 5S launch getting closer, it’s fair to argue that the vast majority of iUsers will be running iOS 7 by the end of the year.

[Via: TUAW]

  • davidwal

    Wow I really need to update my ipad 1st gen to a newer ipad 4 or ipad 3. This is like when I had a iphone 3g when the iphone 4S came out.

Back to top ▴